archrelease: copy trunk to extra-x86_64
[arch-packages.git] / itinerary / trunk / PKGBUILD
blobc738129231e694d66d0811a0025a1e421f8b32f4
1 # Maintainer: Antonio Rojas <arojas@archlinux.org>
3 pkgname=itinerary
4 pkgver=23.04.0
5 pkgrel=1
6 pkgdesc='Itinerary and boarding pass management application'
7 arch=(x86_64)
8 url='https://apps.kde.org/itinerary/'
9 license=(LGPL BSD)
10 depends=(kitinerary kio networkmanager-qt kosmindoormap khealthcertificate qt5-location qqc2-desktop-style prison
11          kitemmodels kunitconversion kfilemetadata kirigami-addons)
12 makedepends=(extra-cmake-modules)
13 groups=(kde-applications kde-pim)
14 source=(https://download.kde.org/stable/release-service/$pkgver/src/$pkgname-$pkgver.tar.xz{,.sig})
15 sha256sums=('438af1c36e3846c2578d857919d51c6b038b87e2d16c2841f27599e20062ea7e'
16             'SKIP')
17 validpgpkeys=(CA262C6C83DE4D2FB28A332A3A6A4DB839EAA6D7  # Albert Astals Cid <aacid@kde.org>
18               F23275E4BF10AFC1DF6914A6DBD2CE893E2D1C87  # Christoph Feck <cfeck@kde.org>
19               D81C0CB38EB725EF6691C385BB463350D6EF31EF) # Heiko Becker <heiko.becker@kde.org>
21 build() {
22   cmake -B build -S $pkgname-$pkgver \
23     -DBUILD_TESTING=OFF
24   cmake --build build
27 package() {
28   DESTDIR="$pkgdir" cmake --install build
30   install -Dm644 $pkgname-$pkgver/LICENSES/* -t "$pkgdir"/usr/share/licenses/$pkgname