archrelease: copy trunk to extra-x86_64
[arch-packages.git] / ktexteditor / repos / extra-x86_64 / PKGBUILD
blobf11e177736579a7a980f883450dd60a3125378eb
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
2 # Maintainer: Antonio Rojas <arojas@archlinux.org>
3 # Contributor: Andrea Scarpino <andrea@archlinux.org>
5 pkgname=ktexteditor
6 pkgver=5.105.0
7 pkgrel=1
8 pkgdesc='Advanced embeddable text editor'
9 arch=(x86_64)
10 url='https://community.kde.org/Frameworks'
11 license=(LGPL)
12 depends=(kparts syntax-highlighting editorconfig-core-c)
13 makedepends=(extra-cmake-modules doxygen qt5-tools qt5-doc)
14 optdepends=('git: git integration')
15 groups=(kf5)
16 source=(https://download.kde.org/stable/frameworks/${pkgver%.*}/$pkgname-$pkgver.tar.xz{,.sig})
17 sha256sums=('96e9dec29a59a6f0fc939b4496dc36138b9d5221e8d1b6c3645ca3d93fd85106'
18             'SKIP')
19 validpgpkeys=(53E6B47B45CEA3E0D5B7457758D0EE648A48B3BB) # David Faure <faure@kde.org>
21 build() {
22   cmake -B build -S $pkgname-$pkgver \
23     -DBUILD_TESTING=OFF \
24     -DBUILD_QCH=ON
25   cmake --build build
28 package() {
29   DESTDIR="$pkgdir" cmake --install build