archrelease: copy trunk to extra-x86_64
[arch-packages.git] / libasyncns / trunk / PKGBUILD
blobfda4c88faafeaf64ee00a493bf2a356b740907df
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Corrado Primier <bardo@aur.archlinux.org>
3 # Contributor: Eric Belanger <belanger@astro.umontreal.ca>
4 # Contributor: William Rea <sillywilly@gmail.com>
5 # Contributor: Daniel J Griffiths <ghost1227@archlinux.us>
7 pkgname=libasyncns
8 pkgver=0.8+r3+g68cd5af
9 pkgrel=2
10 epoch=1
11 pkgdesc="A C library for executing name service queries asynchronously"
12 url="https://0pointer.net/lennart/projects/libasyncns/"
13 arch=(x86_64)
14 license=(LGPL)
15 depends=(glibc)
16 makedepends=(git lynx)
17 _commit=68cd5aff1467638c086f1bedcc750e34917168e4  # master
18 source=("git+https://git.0pointer.net/clone/libasyncns.git#commit=$_commit")
19 sha256sums=('SKIP')
21 pkgver() {
22   cd libasyncns
23   git describe --tags | sed 's/^v//;s/[^-]*-g/r&/;s/-/+/g'
26 prepare() {
27   cd libasyncns
28   NOCONFIGURE=1 ./bootstrap.sh
31 build() {
32   cd libasyncns
33   ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var \
34       --disable-static
35   sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
36   make
39 package() {
40   cd libasyncns
41   make DESTDIR="$pkgdir" install
44 # vim:set sw=2 sts=-1 et: