archrelease: copy trunk to extra-x86_64
[arch-packages.git] / libgweather / trunk / PKGBUILD
blob4db85da74f6ceb5d13c678a7c448707d2450be0f
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Jan de Groot <jgc@archlinux.org>
4 pkgname=libgweather
5 pkgver=40.0+r87+g80e5a652
6 pkgrel=2
7 pkgdesc="Location and timezone database and weather-lookup library"
8 url="https://wiki.gnome.org/Projects/LibGWeather"
9 arch=(x86_64)
10 license=(LGPL)
11 depends=(libsoup gtk3 geocode-glib dconf)
12 makedepends=(gobject-introspection vala git gtk-doc glade meson python-gobject)
13 checkdepends=(python-pylint)
14 _commit=80e5a652405a7c492b252c5196460caa0b05793d  # libgweather-3
15 source=("git+https://gitlab.gnome.org/GNOME/libgweather.git#commit=$_commit"
16         disable-metar-test.diff)
17 sha256sums=('SKIP'
18             'f64afeebdca41198e16a040379e2d6f02ef07784d5ef4d15df381d2c065f588a')
20 pkgver() {
21   cd libgweather
22   git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
25 prepare() {
26   cd libgweather
28   # Avoid test failure without fr_FR.UTF-8 locale
29   git cherry-pick -n 237addd5c02f70c654b69f6697c502590594ae20
31   # Disable metar test, depends on unstable online service
32   git apply -3 ../disable-metar-test.diff
35 build() {
36   arch-meson libgweather build -D gtk_doc=true
37   meson compile -C build
40 check() {
41   meson test -C build --print-errorlogs
44 package() {
45   provides=(libgweather-3.so)
47   meson install -C build --destdir "$pkgdir"
50 # vim:set sw=2 et: