1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
4 pkgname=(librest librest-docs librest-demos)
7 pkgdesc="Library for accessing RESTful web services"
8 url="https://gitlab.gnome.org/GNOME/librest"
11 depends=(glib2 libxml2 libsoup3 json-glib)
12 makedepends=(gobject-introspection git meson gi-docgen vala libadwaita
15 _commit=aa9e968e381ede159414c6338da24d61ad0b5d8b # tags/0.9.1^0
16 source=("git+https://gitlab.gnome.org/GNOME/librest.git#commit=$_commit"
19 'a5e54797a758b67c7f9aa6e90cd7b6435dfa1f7abc86b9b88c0c98e78724b15308ca8af4ccb138d1d01948e54ed9bf930ee37a7d253e6c979846f93f92fef2c2')
23 git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
29 # https://bugs.archlinux.org/task/76560
30 # https://gitlab.gnome.org/GNOME/librest/-/merge_requests/30
31 git apply -3 ../30.patch
35 arch-meson librest build -D vapi=true
36 meson compile -C build
40 meson test -C build --print-errorlogs
44 local p="$1" f d; shift
46 d="$srcdir/$p/${f#$pkgdir/}"
47 mkdir -p "$(dirname "$d")"
49 rmdir -p --ignore-fail-on-non-empty "$(dirname "$f")"
54 depends+=(libg{lib,object,io}-2.0.so libxml2.so libsoup-3.0.so
56 provides+=(librest{,-extras}-1.0.so)
58 meson install -C build --destdir "$pkgdir"
62 _pick docs usr/share/doc
64 _pick demo usr/bin/librest-demo
65 _pick demo usr/share/applications/org.gnome.RestDemo.desktop
68 package_librest-docs() {
69 pkgdesc+=" (documentation)"
74 package_librest-demos() {
75 pkgdesc+=" (demo applications)"
76 depends=(librest libadwaita gtksourceview5)
80 # vim:set sw=2 sts=-1 et: