archrelease: copy trunk to extra-x86_64
[arch-packages.git] / libxcomposite / repos / extra-x86_64 / PKGBUILD
blob0834e492e36a33f4881d0e88386a027a03503a82
1 # Maintainer: Andreas Radke <andyrtr@archlinux.org>
2 # Contributor: Jan de Groot <jgc@archlinux.org>
4 pkgname=libxcomposite
5 pkgver=0.4.6
6 pkgrel=1
7 pkgdesc="X11 Composite extension library"
8 arch=('x86_64')
9 url="https://xorg.freedesktop.org/"
10 license=('custom')
11 depends=('libxfixes')
12 makedepends=('xorg-util-macros' 'xorgproto')
13 options=('debug')
14 source=("${url}/releases/individual/lib/libXcomposite-${pkgver}.tar.xz"{,.sig})
15 sha512sums=('f35a0da8f9f22fd788eee01209557fe3a1b1abdc9744f76330ba42b21b6e3af5464ca4451c33415856417c30da5aa5624e3707980c644327249bfeda5a62a59b'
16             'SKIP')
17 validpgpkeys=('4A193C06D35E7C670FA4EF0BA2FB9E081F2D130E') # "Alan Coopersmith <alan.coopersmith@oracle.com>"
19 build() {
20   cd libXcomposite-${pkgver}
21   ./configure --prefix=/usr --sysconfdir=/etc --disable-static
22   make
25 package() {
26   cd libXcomposite-${pkgver}
27   make DESTDIR="${pkgdir}" install
29   install -m755 -d "${pkgdir}/usr/share/licenses/${pkgname}"
30   install -m644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/"