archrelease: copy trunk to extra-x86_64
[arch-packages.git] / mallard-ducktype / repos / extra-any / PKGBUILD
blobb1eaf5e93aed369b6d63e4ce50659519b3fcf9a5
1 # Maintainer: Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
3 pkgname=mallard-ducktype
4 pkgver=1.0.2
5 pkgrel=9
6 pkgdesc="Parser for the lightweight Ducktype syntax for Mallard"
7 url="http://projectmallard.org"
8 arch=(any)
9 license=(MIT)
10 depends=(python)
11 makedepends=(python-setuptools git)
12 _commit=5d0fe2c23571f4463b77afa1ffd2c2bf5e6316f4  # tags/1.0.2^0
13 source=("git+https://github.com/projectmallard/mallard-ducktype#commit=$_commit")
14 sha256sums=('SKIP')
16 pkgver() {
17   cd $pkgname
18   git describe --tags | sed 's/-/+/g'
21 build() {
22   cd $pkgname
23   python setup.py build
26 package() {
27   cd $pkgname
28   python setup.py install --root="$pkgdir" --optimize=1 --skip-build
29   install -Dt "$pkgdir/usr/share/licenses/$pkgname" -m644 COPYING