1 # Maintainer: Levente Polyak <anthraxx[at]archlinux[dot]org>
2 # Contributor: Gaetan Bisson <bisson@archlinux.org>
3 # Contributor: Angel Velasquez <angvp@archlinux.org>
4 # Contributor: Hugo Doria <hugo@archlinux.org>
9 pkgdesc='Utility for network discovery and security auditing'
10 url='https://nmap.org/'
13 depends=('glibc' 'pcre' 'openssl' 'lua53' 'libpcap'
14 'libssh2' 'libssh2.so' 'zlib' 'gcc-libs')
15 source=("https://nmap.org/dist/${pkgname}-${pkgver}.tar.bz2"
16 "https://nmap.org/dist/sigs/${pkgname}-${pkgver}.tar.bz2.asc")
17 sha256sums=('55bcfe4793e25acc96ba4274d8c4228db550b8e8efd72004b38ec55a2dd16651'
19 b2sums=('e9fa0fe0f219258ab29cf59a98f09142ce1e5e70395f6578d57e644d343ff95764a8208f2fd00a686a14217821adb038a1bb4cdf25f355696e68131773cc1995'
22 '436D66AB9A798425FDA0E3F801AF9F036B9355D0' # Nmap Project Signing Key (http://www.insecure.org/)
26 cd "${pkgname}-${pkgver}"
27 # ensure we build devendored deps
28 rm -rf liblua libpcap libpcre macosx mwin32 libssh2 libz
33 cd "${pkgname}-${pkgver}"
47 cd "${pkgname}-${pkgver}"
52 cd "${pkgname}-${pkgver}"
53 make DESTDIR="${pkgdir}" install
54 install -Dm 644 README.md docs/nmap.usage.txt -t "${pkgdir}/usr/share/doc/${pkgname}"
55 install -Dm 644 LICENSE docs/3rd-party-licenses.txt -t "${pkgdir}/usr/share/licenses/${pkgname}"