archrelease: copy trunk to extra-x86_64
[arch-packages.git] / nmap / trunk / PKGBUILD
blob57b7ff4110f99199a3c4d2d877fd7cea3ccec6cc
1 # Maintainer: Levente Polyak <anthraxx[at]archlinux[dot]org>
2 # Contributor: Gaetan Bisson <bisson@archlinux.org>
3 # Contributor: Angel Velasquez <angvp@archlinux.org>
4 # Contributor: Hugo Doria <hugo@archlinux.org>
6 pkgname=nmap
7 pkgver=7.93
8 pkgrel=1
9 pkgdesc='Utility for network discovery and security auditing'
10 url='https://nmap.org/'
11 arch=('x86_64')
12 license=('GPL2')
13 depends=('glibc' 'pcre' 'openssl' 'lua53' 'libpcap'
14          'libssh2' 'libssh2.so' 'zlib' 'gcc-libs')
15 source=("https://nmap.org/dist/${pkgname}-${pkgver}.tar.bz2"
16         "https://nmap.org/dist/sigs/${pkgname}-${pkgver}.tar.bz2.asc")
17 sha256sums=('55bcfe4793e25acc96ba4274d8c4228db550b8e8efd72004b38ec55a2dd16651'
18             'SKIP')
19 b2sums=('e9fa0fe0f219258ab29cf59a98f09142ce1e5e70395f6578d57e644d343ff95764a8208f2fd00a686a14217821adb038a1bb4cdf25f355696e68131773cc1995'
20         'SKIP')
21 validpgpkeys=(
22   '436D66AB9A798425FDA0E3F801AF9F036B9355D0' # Nmap Project Signing Key (http://www.insecure.org/)
25 prepare() {
26   cd "${pkgname}-${pkgver}"
27   # ensure we build devendored deps
28   rm -rf liblua libpcap libpcre macosx mwin32 libssh2 libz
29   autoreconf -fiv
32 build() {
33   cd "${pkgname}-${pkgver}"
34   ./configure \
35     --prefix=/usr \
36     --with-libpcap=/usr \
37     --with-libpcre=/usr \
38     --with-zlib=/usr \
39     --with-libssh2=/usr \
40     --with-liblua=/usr \
41     --without-ndiff \
42     --without-zenmap
43   make
46 check() {
47   cd "${pkgname}-${pkgver}"
48   make check
51 package() {
52   cd "${pkgname}-${pkgver}"
53   make DESTDIR="${pkgdir}" install
54   install -Dm 644 README.md docs/nmap.usage.txt -t "${pkgdir}/usr/share/doc/${pkgname}"
55   install -Dm 644 LICENSE docs/3rd-party-licenses.txt -t "${pkgdir}/usr/share/licenses/${pkgname}"
58 # vim: ts=2 sw=2 et: