archrelease: copy trunk to extra-x86_64
[arch-packages.git] / perl-file-sharedir / trunk / PKGBUILD
blobe86be07376dfec3763cf5a4f4fa746452014ca71
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Caleb Cushing <xenoterracide@gmail.com>
4 pkgname=perl-file-sharedir
5 _realname=File-ShareDir
6 pkgver=1.118
7 pkgrel=2
8 pkgdesc="Locate per-dist and per-module shared files"
9 arch=(any)
10 license=(PerlArtistic GPL)
11 depends=(perl-class-inspector)
12 url="https://metacpan.org/dist/$_realname"
13 options=('!emptydirs')
14 _author=REHSACK
15 source=("https://cpan.metacpan.org/authors/id/${_author::1}/${_author::2}/${_author}/$_realname-$pkgver.tar.gz")
16 sha256sums=('3bb2a20ba35df958dc0a4f2306fc05d903d8b8c4de3c8beefce17739d281c958')
18 build() {
19   cd $_realname-$pkgver
20   PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
21   make
24 package() {
25   cd $_realname-$pkgver
26   make DESTDIR="$pkgdir" install