archrelease: copy trunk to extra-x86_64
[arch-packages.git] / perl-mime-lite / trunk / PKGBUILD
blobfee0007e1e1c665b72bf533c13e06940a6a0e2bc
1 # Maintainer: kevin <kevin@archlinux.org>
2 # Contributor: Eric Johnson <eric@coding-zone.com>
4 pkgname=perl-mime-lite
5 pkgver=3.033
6 pkgrel=2
7 pkgdesc="Perl module that provides lightweight MIME generator"
8 arch=('any')
9 url="https://search.cpan.org/dist/MIME-Lite/"
10 license=('GPL' 'PerlArtistic')
11 depends=('perl-email-date-format' 'perl-mailtools' 'perl-mime-types' 'perl')
12 options=('!emptydirs')
13 source=("https://search.cpan.org/CPAN/authors/id/R/RJ/RJBS/MIME-Lite-${pkgver}.tar.gz")
14 sha512sums=('315fbe01a432e67953305fb1db70aa337d3c7e1710087196535e108fbb516cf868a277acc693afbbc34ffa135386c6a784ddf4c1de0359fbe6c6339b26aac878')
16 build() {
17   cd MIME-Lite-${pkgver}
18   perl Makefile.PL INSTALLDIRS=vendor
19   make
22 check() {
23   cd MIME-Lite-${pkgver}
24   make test
27 package() {
28   cd MIME-Lite-${pkgver}
29   make DESTDIR="${pkgdir}" install