archrelease: copy trunk to extra-x86_64
[arch-packages.git] / pkcs11-helper / trunk / PKGBUILD
blob8b966feac8427ec729097a31decefb4f5fe0cfb3
1 # Maintainer:
2 # Contributor: Stanislaw Datskevich <me a nek0 net>
3 # Contributor: Gregor Robinson <gregor@fiatflux.co.uk>
4 # Contributor: Martin Perner <martin dot perner at gmail dot com>
6 pkgname=pkcs11-helper
7 pkgver=1.29.0
8 pkgrel=2
9 pkgdesc='A library that simplifies the interaction with PKCS11 providers for end-user applications using a simple API and optional OpenSSL engine'
10 arch=('x86_64')
11 url='https://github.com/OpenSC/pkcs11-helper'
12 license=('GPL' 'BSD')
13 depends=('gnutls' 'nss' 'openssl')
14 provides=('libpkcs11-helper.so')
15 source=("https://github.com/OpenSC/${pkgname}/releases/download/${pkgname}-${pkgver}/${pkgname}-${pkgver}.tar.bz2")
16 sha256sums=('996846a3c8395e03d8c0515111dc84d82e6e3648d44ba28cb2dbbbca2d4db7d6')
18 build() {
19   cd pkcs11-helper-$pkgver
21   libtoolize
22   aclocal
23   autoheader
24   automake --add-missing
25   autoreconf -v
26   ./configure --prefix=/usr
27   make
30 package() {
31   cd pkcs11-helper-$pkgver
33   make DESTDIR="$pkgdir" install
34   mkdir -p "$pkgdir"/usr/share/licenses/$pkgname/
35   install -D -m0644 COPYING* "$pkgdir"/usr/share/licenses/$pkgname/