archrelease: copy trunk to extra-x86_64
[arch-packages.git] / python-chardet / trunk / PKGBUILD
blob31a02a523a61fe20d19fe31a6d6a8a362755ba8f
1 # Maintainer : Felix Yan <felixonmars@archlinux.org>
2 # Contributor: Ionut Biru <ibiru@archlinux.org>
3 # Contributor: William Rea <sillywilly@gmail.com>
5 pkgname=python-chardet
6 pkgver=5.1.0
7 pkgrel=3
8 arch=('any')
9 url="https://github.com/chardet/chardet"
10 license=('LGPL')
11 depends=('python')
12 pkgdesc="Python3 module for character encoding auto-detection"
13 makedepends=('python-build' 'python-installer' 'python-setuptools' 'python-wheel')
14 checkdepends=('python-pytest')
15 source=("https://pypi.io/packages/source/c/chardet/chardet-${pkgver}.tar.gz")
16 sha512sums=('f4e668de1d6f8fe0223d79a150123b99875cc5e2015e2b6c4052c1c545c044f1a3aba1c02eba3c295c0a1795e24302f5304500321dca8f1e8c0605d08ef8bb62')
18 build() {
19    cd chardet-$pkgver
20    python -m build --wheel --no-isolation
23 check() {
24    cd chardet-$pkgver
25    python -m pytest
28 package() {
29    cd chardet-$pkgver
30    python -m installer --destdir="$pkgdir" dist/*.whl