1 # Maintainer: Johannes Löthberg <johannes@kyriasis.com>
3 pkgname=python-prometheus_client
7 pkgdesc="Prometheus instrumentation library for Python applications"
8 url="https://github.com/prometheus/client_python"
13 makedepends=('python-setuptools')
14 checkdepends=('python-twisted' 'python-pytest')
16 source=(client_python-$pkgver.tar.gz::https://github.com/prometheus/client_python/archive/v${pkgver}.tar.gz)
18 sha512sums=('511936758026b6d6f48f52d27b1cb964a03668054d7a3c5c82c4fa20800be3812150fca74ab46dad11ca12f2c9ce1a6951a82ae2bacf91b3761f7bf7ce75e0d2')
21 cd client_python-$pkgver
26 cd client_python-$pkgver
27 # Make reproducible by not writing pyc files for test files. (rebuilderd does not run tests)
28 PYTHONDONTWRITEBYTECODE=1 python -m unittest discover -vs .
32 cd client_python-$pkgver
33 python setup.py install --root="$pkgdir" --skip-build --optimize=1