1 # Maintainer: Jelle van der Waa <jelle@archlinux.org>
3 pkgname=python-pytest-pacman
6 pkgdesc="pacman db pytest fixture"
9 url="https://gitlab.archlinux.org/archlinux/pytest-pacman"
10 depends=(python python-pytest python-setuptools)
11 makedepends=(python-build python-installer python-wheel python-flit-core git)
12 source=(git+https://gitlab.archlinux.org/archlinux/pytest-pacman.git?signed#tag=v${pkgver})
13 validpgpkeys=("E499C79F53C96A54E572FEE1C06086337C50773E")
19 python -m build --wheel --no-isolation
25 python -m installer --destdir="$pkgdir" dist/*.whl
27 install -Dm 644 README.md -t "${pkgdir}/usr/share/doc/${pkgname}"
28 install -Dm 644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"