archrelease: copy trunk to extra-x86_64
[arch-packages.git] / python-pytest-pacman / repos / extra-any / PKGBUILD
blobcd54bfe477923c945edc5a5d2ebd0393e87edaf8
1 # Maintainer: Jelle van der Waa <jelle@archlinux.org>
3 pkgname=python-pytest-pacman
4 pkgver=0.1.1
5 pkgrel=1
6 pkgdesc="pacman db pytest fixture"
7 arch=('any')
8 license=('MIT')
9 url="https://gitlab.archlinux.org/archlinux/pytest-pacman"
10 depends=(python python-pytest python-setuptools)
11 makedepends=(python-build python-installer python-wheel python-flit-core git)
12 source=(git+https://gitlab.archlinux.org/archlinux/pytest-pacman.git?signed#tag=v${pkgver})
13 validpgpkeys=("E499C79F53C96A54E572FEE1C06086337C50773E")
14 sha512sums=('SKIP')
16 build() {
17   cd pytest-pacman
19   python -m build --wheel --no-isolation
22 package() {
23   cd pytest-pacman
25   python -m installer --destdir="$pkgdir" dist/*.whl
27   install -Dm 644 README.md -t "${pkgdir}/usr/share/doc/${pkgname}"
28   install -Dm 644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"