archrelease: copy trunk to extra-x86_64
[arch-packages.git] / qt5-webglplugin / trunk / PKGBUILD
blob8960eafca600103be8c1ac5cd1f1ca008a3844a0
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
2 # Maintainer: Antonio Rojas <arojas@archlinux.org>
4 pkgname=qt5-webglplugin
5 _basever=5.15.9
6 pkgver=5.15.9
7 pkgrel=1
8 _commit=64beacdd2d0f6fe0796bd291c9ab33f206a333c3
9 arch=(x86_64)
10 url='https://www.qt.io'
11 license=(GPL3 LGPL3 FDL custom)
12 pkgdesc='QPA plugin for running an application via a browser using streamed WebGL commands'
13 depends=(qt5-websockets qt5-declarative)
14 makedepends=(git)
15 groups=(qt qt5)
16 _pkgfqn=${pkgname/5-/}
17 source=(git+https://invent.kde.org/qt/qt/$_pkgfqn#commit=$_commit)
18 sha256sums=('SKIP')
20 pkgver() {
21   cd $_pkgfqn
22   echo "$_basever+kde+r"`git rev-list --count v$_basever-lts-lgpl..$_commit` | sed -e 's|+kde+r0||'
25 prepare() {
26   mkdir -p build
29 build() {
30   cd build
32   qmake ../${_pkgfqn}
33   make
36 package() {
37   cd build
38   make INSTALL_ROOT="$pkgdir" install
40   # Drop QMAKE_PRL_BUILD_DIR because reference the build dir
41   find "$pkgdir/usr/lib" -type f -name '*.prl' \
42     -exec sed -i -e '/^QMAKE_PRL_BUILD_DIR/d' {} \;
44   install -d "$pkgdir"/usr/share/licenses
45   ln -s /usr/share/licenses/qt5-base "$pkgdir"/usr/share/licenses/${pkgname}