1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Jason Chu <jason@archlinux.org>
7 pkgdesc="A free codec for free speech"
8 url="https://www.speex.org/"
11 depends=(gcc-libs libogg speexdsp)
13 _commit=5dceaaf3e23ee7fd17c80cb5f02a838fd6c18e01 # tags/Speex-1.2.1^0
14 source=("git+https://gitlab.xiph.org/xiph/speex.git#commit=$_commit")
19 git describe --tags | sed 's/^Speex-//;s/[^-]*-g/r&/;s/-/+/g'
29 ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var \
32 sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
42 depends+=(libogg.so libspeexdsp.so)
43 provides+=(libspeex.so)
46 make DESTDIR="$pkgdir" install
47 install -Dt "$pkgdir/usr/share/licenses/$pkgname" -m644 COPYING