archrelease: copy trunk to extra-x86_64
[arch-packages.git] / xfce4-smartbookmark-plugin / trunk / PKGBUILD
blob9c6beda723d9e67f06608302465994db34d8c3cc
1 # Maintainer: Evangelos Foutras <evangelos@foutrelis.com>
2 # Contributor: AndyRTR <andyrtr@archlinux.org>
3 # Contributor: Tobias Kieslich <tobias (at) archlinux.org>
5 pkgname=xfce4-smartbookmark-plugin
6 pkgver=0.5.2
7 pkgrel=1
8 pkgdesc="Allows you to send requests directly to your browser and perform a custom search"
9 arch=('x86_64')
10 url="https://docs.xfce.org/panel-plugins/xfce4-smartbookmark-plugin"
11 license=('GPL2')
12 groups=('xfce4-goodies')
13 depends=('xfce4-panel')
14 makedepends=('intltool' 'libxt')
15 source=(https://archive.xfce.org/src/panel-plugins/$pkgname/${pkgver%.*}/$pkgname-$pkgver.tar.bz2
16         xfce4-smartbookmark-plugin-archlinux.patch)
17 sha256sums=('2a279e2f5a54518684e62ad1f3cd8ef950826505b39725f1b5d8f0c43031cdd3'
18             '077092f164317327ccea49692fe166ad1dc7ff0cbbaf9863e5f0d11ca077b7e5')
20 prepare() {
21   cd "$srcdir/$pkgname-$pkgver"
23   patch -Np1 -i "$srcdir/xfce4-smartbookmark-plugin-archlinux.patch"
26 build() {
27   cd "$srcdir/$pkgname-$pkgver"
29   ./configure \
30     --prefix=/usr \
31     --sysconfdir=/etc \
32     --libexecdir=/usr/lib \
33     --localstatedir=/var \
34     --disable-static \
35     --disable-debug
36   make
39 package() {
40   cd "$srcdir/$pkgname-$pkgver"
41   make DESTDIR="$pkgdir" install
44 # vim:set ts=2 sw=2 et: