archrelease: copy trunk to extra-x86_64
[arch-packages.git] / xorg-xwayland / trunk / PKGBUILD
blob18936344bb2e1d7f8a8821af0f5c28a195a2e4e5
1 # Maintainer: AndyRTR <andyrtr@archlinux.org>
3 pkgname=xorg-xwayland
4 pkgver=23.1.1
5 pkgrel=1
6 arch=('x86_64')
7 license=('custom')
8 groups=('xorg')
9 url="https://xorg.freedesktop.org"
10 pkgdesc="run X clients under wayland"
11 depends=('nettle' 'libepoxy' 'systemd-libs' 'libxfont2' 
12          'pixman' 'xorg-server-common' 'libxcvt' 'mesa')
13 makedepends=('meson' 'xorgproto' 'xtrans' 'libxkbfile' 'dbus'
14              'xorg-font-util'
15              'wayland' 'wayland-protocols'
16              'libdrm' 'mesa-libgl'
17              'systemd'
18              'egl-wayland'
20 source=(https://xorg.freedesktop.org/archive/individual/xserver/xwayland-$pkgver.tar.xz{,.sig})
21 sha512sums=('21c386847135c5cb4ac884926b0fbeb6ad21c9ee54752e0cdc8418e31a72872d81032159c1d91b8afb915aaaf65e80454342461d676996b2f3c535a37b0147f0'
22             'SKIP')
23 provides=('xorg-server-xwayland')
24 conflicts=('xorg-server-xwayland')
25 replaces=('xorg-server-xwayland')
26 #validpgpkeys=('B09FAF35BE914521980951145A81AF8E6ADBB200') # "Michel Daenzer <michel@daenzer.net>"
27 validpgpkeys=('67DC86F2623FC5FD4BB5225D14706DBE1E4B4540') # "Olivier Fourdan <fourdan@xfce.org>"
28 #validpgpkeys=('3C2C43D9447D5938EF4551EBE23B7E70B467F0BF') # Peter Hutterer (Who-T) <office@who-t.net>
31 build() {
32   arch-meson xwayland-$pkgver build \
33     -D ipv6=true \
34     -D xvfb=false \
35     -D xdmcp=false \
36     -D xcsecurity=true \
37     -D dri3=true \
38     -D xwayland_eglstream=true \
39     -D glamor=true \
40     -D xkb_dir=/usr/share/X11/xkb \
41     -D xkb_output_dir=/var/lib/xkb
43   # Print config
44   meson configure build
45   ninja -C build
48 package() {
50   DESTDIR="${pkgdir}" ninja -C build install
51   # xorg-server-common file /usr/lib/xorg/protocol.txt
52   rm "${pkgdir}"/usr/lib/xorg/protocol.txt
53   rmdir "${pkgdir}"/usr/lib/xorg
54   rm "${pkgdir}"/usr/share/man/man1/Xserver.1
56   # license
57   install -m644 -Dt "${pkgdir}/usr/share/licenses/${pkgname}" xwayland-$pkgver/COPYING