archrelease: copy trunk to extra-x86_64
[arch-packages.git] / zenity / trunk / PKGBUILD
blobb40b9cfeeea05f29a608f303bda8f8888f12f641
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Jan de Groot <jgc@archlinux.org>
4 pkgname=zenity
5 pkgver=3.44.1
6 pkgrel=1
7 pkgdesc="Display graphical dialog boxes from shell scripts"
8 url="https://gitlab.gnome.org/GNOME/zenity"
9 arch=(x86_64)
10 license=(LGPL)
11 depends=(
12   gtk3
13   libnotify
15 makedepends=(
16   git
17   meson
18   yelp-tools
20 optdepends=('perl: gdialog wrapper')
21 _commit=5cb56e3e87dcbb1fb423ecee436a62bde483b611  # tags/3.44.1^0
22 source=("git+https://gitlab.gnome.org/GNOME/zenity.git#commit=$_commit")
23 b2sums=('SKIP')
25 pkgver() {
26   cd zenity
27   git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
30 prepare() {
31   cd zenity
34 build() {
35   local meson_options=(
36     -D libnotify=true
37   )
39   arch-meson zenity build "${meson_options[@]}"
40   meson compile -C build
43 check() {
44   meson test -C build --print-errorlogs
47 package() {
48   meson install -C build --destdir "$pkgdir"
51 # vim:set sw=2 sts=-1 et: