archrelease: copy trunk to extra-x86_64
[arch-packages.git] / cppunit / repos / extra-x86_64 / PKGBUILD
blobdb3622fd13d07d61b0d2ad5c7d7f47bdec07dff0
1 # Maintainer: Stéphane Gaudreault <stephane@archlinux.org>
2 # Contributor: Jeff 'codemac' Mickey <jeff@archlinux.org>
4 pkgname=cppunit
5 pkgver=1.15.1
6 pkgrel=2
7 pkgdesc="A C++ unit testing framework"
8 arch=('x86_64')
9 url="https://www.freedesktop.org/wiki/Software/cppunit"
10 license=('LGPL')
11 depends=('sh' 'gcc-libs')
12 makedepends=('doxygen')
13 options=('!emptydirs')
14 source=(https://dev-www.libreoffice.org/src/${pkgname}-${pkgver}.tar.gz)
15 sha256sums=('89c5c6665337f56fd2db36bc3805a5619709d51fb136e51937072f63fcc717a7')
17 build() {
18    cd ${pkgname}-${pkgver}
19    ./configure --prefix=/usr --disable-static
20    make
23 check() {
24   cd ${pkgname}-${pkgver}
25   make check
28 package() {
29    cd ${pkgname}-${pkgver}
30    make DESTDIR="${pkgdir}" install