archrelease: copy trunk to extra-x86_64
[arch-packages.git] / fluidsynth / repos / extra-x86_64 / PKGBUILD
blob5a8bd59ae322fe8c4e78291666483eedfffda4ab
1 # Maintainer: David Runge <dvzrv@archlinux.org>
2 # Contributor: Ray Rashif <schiv@archlinux.org>
3 # Contributor: damir <damir@archlinux.org>
5 pkgname=fluidsynth
6 pkgver=2.2.4
7 pkgrel=1
8 pkgdesc="A real-time software synthesizer based on the SoundFont 2 specifications"
9 arch=(x86_64)
10 url="https://www.fluidsynth.org/"
11 license=(LGPL2.1)
12 groups=(pro-audio)
13 depends=(glibc sdl2)
14 makedepends=(alsa-lib cmake dbus doxygen glib2 jack ladspa libinstpatch
15 libpulse libsndfile portaudio readline systemd-libs)
16 provides=(libfluidsynth.so soundfont-synthesizer)
17 backup=("etc/conf.d/$pkgname")
18 source=("$pkgname-$pkgver.tar.gz::https://github.com/${pkgname}/${pkgname}/archive/v$pkgver.tar.gz")
19 sha512sums=('46c3f0759cc011f34e5ba80684df4e8b593315d564da2341aaea14a5f0ba9cf732933f6ebc8712506f194b044a8e2b198b9e50879ff4221e6a9ab8051e79b48f')
20 b2sums=('28a2a8048ad3f652afd424358b1b268d42672eb8fba0bdb30c72c06041617844fb5b90bc922e905d80ca2818eac03e9e5ce7f9a57b4cf68a43f60ed4bfddcd49')
22 build() {
23   cd "${pkgname}-${pkgver}"
24   cmake -DCMAKE_INSTALL_PREFIX=/usr \
25         -DCMAKE_BUILD_TYPE=None \
26         -DFLUID_DAEMON_ENV_FILE=/etc/conf.d/fluidsynth \
27         -Denable-ladspa=ON \
28         -Denable-portaudio=ON \
29         -DLIB_SUFFIX="" \
30         -Wno-dev \
31         -B build \
32         -S .
33   make -C build VERBOSE=1
36 check() {
37   cd "${pkgname}-${pkgver}"
38   make -C build -k check
41 package() {
42   depends+=(libasound.so libdbus-1.so libglib-2.0.so libgmodule-2.0.so
43   libgobject-2.0.so libinstpatch-1.0.so libjack.so libportaudio.so
44   libpulse-simple.so libreadline.so libsndfile.so libsystemd.so)
46   cd "${pkgname}-${pkgver}"
47   make -C build DESTDIR="$pkgdir" install
48   # systemd user unit
49   install -vDm 644 "build/${pkgname}.service" -t "$pkgdir/usr/lib/systemd/user/"
50   # system-wide configuration file
51   install -vDm 644 "build/${pkgname}.conf" "${pkgdir}/etc/conf.d/${pkgname}"
52   # docs
53   install -vDm 644 {AUTHORS,ChangeLog,{CONTRIBUTING,README}.md,THANKS,TODO} -t "${pkgdir}/usr/share/doc/${pkgname}"