1 # Maintainer: AndyRTR <andyrtr@archlinux.org>
6 pkgdesc="a C/C++ client library for the CMIS protocol"
8 url="https://github.com/tdf/libcmis"
9 license=('GPL2' 'LGPL2.1' 'MPL')
10 depends=('boost-libs' 'curl' 'libxml2')
11 makedepends=('docbook2x' 'cppunit' 'boost')
12 source=("https://github.com/tdf/libcmis/releases/download/v${pkgver}/$pkgname-$pkgver.tar.gz"
13 'libcmis-0.5.2-icu-64.2.patch')
14 sha256sums=('ed6f681a48abbf3c2324564b17a180d21fa9503230e8708825e1ad80daee4f81'
15 '51b67a5b7245e5192739362c5034ed7d9a664799f38ff9ccd1832297f93cc03d')
20 # https://github.com/tdf/libcmis/issues/35
21 patch -Np1 -i ../libcmis-0.5.2-icu-64.2.patch
26 ./configure --prefix=/usr DOCBOOK2MAN='db2x_docbook2man' --disable-werror
27 sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
33 # fails a google drive check - fix will be included in the next release
34 make check || /bin/true
39 make DESTDIR="$pkgdir/" install