archrelease: copy trunk to extra-x86_64
[arch-packages.git] / libnl / trunk / PKGBUILD
blob7904c3bfd4ee02bece3ab0946035c6d3e4fb8c43
1 # Maintainer:  Bartłomiej Piotrowski <bpiotrowski@archlinux.org>
2 # Contributor: Thomas Bächler <thomas@archlinux.org>
4 pkgname=libnl
5 pkgver=3.5.0
6 pkgrel=3
7 pkgdesc='Library for applications dealing with netlink sockets'
8 arch=(x86_64)
9 url='https://github.com/thom311/libnl/'
10 license=(GPL)
11 depends=(glibc)
12 backup=(etc/libnl/classid etc/libnl/pktloc)
13 source=(https://github.com/thom311/libnl/releases/download/libnl${pkgver//./_}/${pkgname}-${pkgver}.tar.gz{,.sig})
14 sha256sums=('352133ec9545da76f77e70ccb48c9d7e5324d67f6474744647a7ed382b5e05fa'
15             'SKIP')
16 validpgpkeys=('49EA7C670E0850E7419514F629C2366E4DFC5728') # Thomas Haller
18 build() {
19   cd $pkgname-$pkgver
20   ./configure \
21     --prefix=/usr \
22     --sysconfdir=/etc \
23     --sbindir=/usr/bin \
24     --disable-static
25   make
28 check() {
29   make -C $pkgname-$pkgver check
32 package() {
33   make -C $pkgname-$pkgver DESTDIR="$pkgdir" install