db-move: moved webkitgtk-6.0 from [testing] to [extra] (x86_64)
[arch-packages.git] / dbus-python / repos / extra-x86_64 / PKGBUILD
blob19f46bea1a987f7bc27571f99a4070bb5de97868
1 # Maintainer: Jan de Groot <jgc@archlinux.org>
3 pkgname=dbus-python
4 pkgver=1.2.18
5 pkgrel=5
6 pkgdesc="Python bindings for DBUS"
7 url="https://www.freedesktop.org/wiki/Software/DBusBindings"
8 arch=(x86_64)
9 license=('GPL' 'LGPL')
10 depends=('dbus' 'glib2' 'python')
11 makedepends=('autoconf-archive' 'python-sphinx_rtd_theme' 'python-sphinx')
12 source=(https://dbus.freedesktop.org/releases/${pkgname}/${pkgname}-${pkgver}.tar.gz{,.asc})
13 sha256sums=('92bdd1e68b45596c833307a5ff4b217ee6929a1502f5341bae28fd120acf7260'
14             'SKIP')
15 validpgpkeys=('DA98F25C0871C49A59EAFF2C4DE8FF2A63C7CC90')
16 replaces=('python-dbus' 'python-dbus-common')
17 conflicts=('python-dbus' 'python-dbus-common')
18 provides=("python-dbus=$pkgver" "python-dbus-common=$pkgver")
20 prepare() {
21   cd $pkgname-$pkgver
22   autoreconf -vfi
25 build() {
26   cd $pkgname-$pkgver
27   ./configure --prefix=/usr
28   sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
29   make
32 package() {
33   cd $pkgname-$pkgver
34   make DESTDIR="${pkgdir}" install