db-move: moved webkitgtk-6.0 from [testing] to [extra] (x86_64)
[arch-packages.git] / gmp / repos / core-x86_64 / PKGBUILD
blobe66f32d43cb9aae70fd54c6e1d4542af5d687647
1 # Maintainer: Allan McRae <allan@archlinux.org>
2 # Contributer: Jan de Groot <jgc@archlinux.org>
4 pkgname=gmp
5 pkgver=6.2.1
6 pkgrel=2
7 pkgdesc='A free library for arbitrary precision arithmetic'
8 arch=(x86_64)
9 url='https://gmplib.org/'
10 depends=(gcc-libs sh)
11 license=(LGPL3 GPL)
12 source=(https://gmplib.org/download/gmp/gmp-$pkgver.tar.lz{,.sig})
13 md5sums=('03a31d8cbaf29d136252f8f38875ed82'
14          'SKIP')
15 validpgpkeys=('343C2FF0FBEE5EC2EDBEF399F3599FF828C67298')   # Niels Möller
16 options=(debug)
18 build() {
19   cd $pkgname-$pkgver
21   ./configure --build=${CHOST} \
22     --prefix=/usr \
23     --enable-cxx \
24     --enable-fat
25   make
28 check() {
29   cd $pkgname-$pkgver
30   make check
33 package() {
34   cd $pkgname-$pkgver
35   make DESTDIR="${pkgdir}" install