db-move: moved webkitgtk-6.0 from [testing] to [extra] (x86_64)
[arch-packages.git] / gzip / repos / core-x86_64 / PKGBUILD
blob734dbd198bddd92094e569702b433abd2589e355
1 # Maintainer: Sébastien "Seblu" Luttringer <seblu@archlinux.org>
2 # Contributor: Allan McRae <allan@archlinux.org>
3 # Contributor: judd <jvinet@zeroflux.org>
5 pkgname=gzip
6 pkgver=1.12
7 pkgrel=2
8 pkgdesc='GNU compression utility'
9 arch=('x86_64')
10 url='https://www.gnu.org/software/gzip/'
11 license=('GPL3')
12 depends=('glibc' 'bash' 'less')
13 validpgpkeys=('155D3FC500C834486D1EEA677FD9FCCB000BEEEE') # Jim Meyering
14 source=("https://ftp.gnu.org/pub/gnu/gzip/gzip-$pkgver.tar.xz"{,.sig})
15 sha256sums=('ce5e03e519f637e1f814011ace35c4f87b33c0bbabeec35baf5fbd3479e91956'
16             'SKIP')
17 prepare() {
18   cd $pkgname-$pkgver
19   # apply patch from the source array (should be a pacman feature)
20   local filename
21   for filename in "${source[@]}"; do
22     if [[ "$filename" =~ \.patch$ ]]; then
23       echo "Applying patch ${filename##*/}"
24       patch -p1 -N -i "$srcdir/${filename##*/}"
25     fi
26   done
27   :
30 build() {
31   cd $pkgname-$pkgver
32   ./configure --prefix=/usr
33   make
36 check() {
37   cd $pkgname-$pkgver
38   make check
41 package() {
42   cd $pkgname-$pkgver
43   make prefix="$pkgdir/usr" install
46 # vim:set ts=2 sw=2 et: