1 # Maintainer: Sébastien "Seblu" Luttringer <seblu@archlinux.org>
2 # Contributor: Allan McRae <allan@archlinux.org>
3 # Contributor: judd <jvinet@zeroflux.org>
8 pkgdesc='GNU compression utility'
10 url='https://www.gnu.org/software/gzip/'
12 depends=('glibc' 'bash' 'less')
13 validpgpkeys=('155D3FC500C834486D1EEA677FD9FCCB000BEEEE') # Jim Meyering
14 source=("https://ftp.gnu.org/pub/gnu/gzip/gzip-$pkgver.tar.xz"{,.sig})
15 sha256sums=('ce5e03e519f637e1f814011ace35c4f87b33c0bbabeec35baf5fbd3479e91956'
19 # apply patch from the source array (should be a pacman feature)
21 for filename in "${source[@]}"; do
22 if [[ "$filename" =~ \.patch$ ]]; then
23 echo "Applying patch ${filename##*/}"
24 patch -p1 -N -i "$srcdir/${filename##*/}"
32 ./configure --prefix=/usr
43 make prefix="$pkgdir/usr" install
46 # vim:set ts=2 sw=2 et: