1 # Maintainer: Pierre Schmitz <pierre@archlinux.de>
2 # Contributor: Alexandre Bique <bique.alexandre@gmail.com>
7 pkgdesc='A standalone and lightweight BitTorrent tracker'
9 url='https://github.com/abique/hefur'
11 makedepends=('git' 'cmake')
12 depends=('gnutls' 'xz' 'protobuf')
13 source=("git+https://github.com/abique/${pkgname}.git#tag=${pkgver}"
14 'hefurd.service' 'tmpfiles.conf' 'sysusers.conf')
16 'd9359b0e1c54ef2d286c6161eb742d442ba1b766'
17 'f482ed1715d5a375c4a8d1906436b946c0b02157'
18 '306db71b24ea5ca3429b6f482ab310fc7cfde63c')
21 cd "${srcdir}/${pkgname}"
22 git submodule set-url mimosa https://github.com/abique/mimosa.git
25 sed -i "s/PROJECT_NUMBER.*/PROJECT_NUMBER=${pkgver}/g" Doxyfile
26 sed -i "s/tracker-controller.hh//g" hefur/CMakeLists.txt
30 cd "${srcdir}/${pkgname}"
33 cmake -DCMAKE_INSTALL_PREFIX=/usr ..
38 cd "${srcdir}/${pkgname}/build"
39 DESTDIR="${pkgdir}" make install
40 install -D -m644 "${srcdir}/hefurd.service" "${pkgdir}/usr/lib/systemd/system/hefurd.service"
41 install -D -m644 "${srcdir}/tmpfiles.conf" "${pkgdir}/usr/lib/tmpfiles.d/hefurd.conf"
42 install -D -m644 "${srcdir}/sysusers.conf" "${pkgdir}/usr/lib/sysusers.d/hefurd.conf"
43 install -D -m644 "${srcdir}/${pkgname}/LICENSE.md" "${pkgdir}/usr/share/licenses/hefur/LICENSE"