db-move: moved webkitgtk-6.0 from [testing] to [extra] (x86_64)
[arch-packages.git] / kdenlive / trunk / PKGBUILD
blob5b79a01b6fa6af9d7474ed2347c7a670aa33c523
1 # Maintainer: Antonio Rojas <arojas@archlinux.org>
2 # Contributor: Sergej Pupykin <pupykin.s+arch@gmail.com>
3 # Contributor: Zuf <kontakt.zuf@gmail.com>
4 # Contributor: Darwin Bautista <djclue917@gmail.com>
5 # Contributor: Gustavo Alvarez <sl1pkn07@gmail.com>
7 pkgname=kdenlive
8 pkgver=23.04.0
9 pkgrel=2
10 pkgdesc='A non-linear video editor for Linux using the MLT video framework'
11 arch=(x86_64)
12 url='https://apps.kde.org/kdenlive/'
13 license=(GPL)
14 groups=(kde-applications kde-multimedia)
15 depends=(qt5-networkauth knewstuff knotifyconfig kfilemetadata purpose mlt breeze-icons frei0r-plugins)
16 makedepends=(extra-cmake-modules kdoctools v4l-utils doxygen qt5-tools)
17 optdepends=('ffmpeg: for FFmpeg plugin'
18             'dvgrab: for firewire capture'
19             'recordmydesktop: for screen capture'
20             'opencv: for motion tracking'
21             'plasma-desktop: theme configuration'
22             'opentimelineio: timeline export/import'
23             'bigsh0t: VR360 effects'
24             'mediainfo: for technical clip information'
25             'noise-suppression-for-voice: noise suppression effect')
26 source=(https://download.kde.org/stable/release-service/$pkgver/src/$pkgname-$pkgver.tar.xz{,.sig}
27         https://invent.kde.org/multimedia/kdenlive/-/commit/364e23f6.patch)
28 makedepends+=(git) # patch is binary
29 sha256sums=('eba17db62714e56eb9433499d559dab0657677c6876b0735a756b0d9afc48e6a'
30             'SKIP'
31             'abc63b230a9f98981533640a011c793ccf03f693d78330c19c1dbb6eca08feb4')
32 validpgpkeys=(CA262C6C83DE4D2FB28A332A3A6A4DB839EAA6D7  # Albert Astals Cid <aacid@kde.org>
33               F23275E4BF10AFC1DF6914A6DBD2CE893E2D1C87  # Christoph Feck <cfeck@kde.org>
34               D81C0CB38EB725EF6691C385BB463350D6EF31EF) # Heiko Becker <heiko.becker@kde.org>
36 prepare() {
37   cd $pkgname-$pkgver
38   git apply ../364e23f6.patch # Fix project corruption
41 build() {
42   cmake -B build -S $pkgname-$pkgver \
43     -DBUILD_TESTING=OFF \
44     -DBUILD_QCH=ON
45   cmake --build build
48 package() {
49   DESTDIR="$pkgdir" cmake --install build