db-move: moved webkitgtk-6.0 from [testing] to [extra] (x86_64)
[arch-packages.git] / kpimtextedit / trunk / PKGBUILD
blobf9efcf135e0334a2b7404e8e78971a327f5a5e8e
1 # Maintainer: Antonio Rojas <arojas@archlinux.org>
3 pkgname=kpimtextedit
4 pkgver=23.04.0
5 pkgrel=2
6 pkgdesc='A textedit with PIM-specific features'
7 arch=(x86_64)
8 url='https://kontact.kde.org'
9 license=(LGPL)
10 depends=(kio syntax-highlighting)
11 makedepends=(extra-cmake-modules qt5-tools doxygen)
12 source=(https://download.kde.org/stable/release-service/$pkgver/src/$pkgname-$pkgver.tar.xz{,.sig}
13         fix-qch-install.patch)
14 sha256sums=('cc6819004d5e73aae9b3b8f0679b79cf49f1d3b9c9f0451e78bd1ef809319cf1'
15             'SKIP'
16             'c89bbab9780e9a35db2de527a846066711e7398bd0fe4797d303f09c6acea7ad')
17 validpgpkeys=(CA262C6C83DE4D2FB28A332A3A6A4DB839EAA6D7  # Albert Astals Cid <aacid@kde.org>
18               F23275E4BF10AFC1DF6914A6DBD2CE893E2D1C87  # Christoph Feck <cfeck@kde.org>
19               D81C0CB38EB725EF6691C385BB463350D6EF31EF) # Heiko Becker <heiko.becker@kde.org>
21 prepare() {
22   patch -d $pkgname-$pkgver -p1 < fix-qch-install.patch # Install QCH targets to backwards-compatible path
25 build() {
26   cmake -B build -S $pkgname-$pkgver \
27     -DBUILD_TESTING=OFF \
28     -DBUILD_QCH=ON
29   cmake --build build
32 package() {
33   DESTDIR="$pkgdir" cmake --install build