db-move: moved webkitgtk-6.0 from [testing] to [extra] (x86_64)
[arch-packages.git] / kquickcharts / trunk / PKGBUILD
blob9c5418e8c9e754dbb600342a9101e4adf6426545
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
2 # Maintainer: Antonio Rojas <arojas@archlinux.org>
4 pkgname=kquickcharts
5 pkgver=5.105.0
6 pkgrel=1
7 pkgdesc='A QtQuick plugin providing high-performance charts'
8 arch=(x86_64)
9 url='https://community.kde.org/Frameworks'
10 license=(LGPL)
11 depends=(qt5-quickcontrols2)
12 makedepends=(extra-cmake-modules)
13 groups=(kf5)
14 source=(https://download.kde.org/stable/frameworks/${pkgver%.*}/$pkgname-$pkgver.tar.xz{,.sig})
15 sha256sums=('8a24080bcbe3d74e65c4d64e3cf51255fc9d41d677ba78360e1a0f8684b2c903'
16             'SKIP')
17 validpgpkeys=(53E6B47B45CEA3E0D5B7457758D0EE648A48B3BB) # David Faure <faure@kde.org>
19 build() {
20   cmake -B build -S $pkgname-$pkgver \
21     -DBUILD_TESTING=OFF
22   cmake --build build
25 package() {
26   DESTDIR="$pkgdir" cmake --install build