db-move: moved webkitgtk-6.0 from [testing] to [extra] (x86_64)
[arch-packages.git] / libdmapsharing / repos / extra-x86_64 / PKGBUILD
blobf79ea08af024562f36399b7c76b01570b02f09d8
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Ionut Biru <ibiru@archlinux.org>
4 pkgname=libdmapsharing
5 pkgver=3.9.12
6 pkgrel=1
7 pkgdesc="A library that implements the DMAP family of protocols"
8 url="https://www.flyn.org/projects/libdmapsharing/index.html"
9 arch=(x86_64)
10 license=(LGPL2.1)
11 depends=(
12   avahi
13   gdk-pixbuf2
14   gst-plugins-base-libs
15   libsoup3
17 makedepends=(
18   git
19   gobject-introspection
20   gtk-doc
21   vala
23 provides=(libdmapsharing-4.0.so)
24 _commit=2bcf6286fc81ff9c964e5b1bfe918c01a18e98c4  # tags/LIBDMAPSHARING_3_9_12^0
25 source=("git+https://gitlab.gnome.org/GNOME/libdmapsharing.git#commit=$_commit")
26 b2sums=('SKIP')
28 pkgver() {
29   cd $pkgname
30   git describe --tags | sed 's/^LIBDMAPSHARING_//;s/_/./g;s/[^-]*-g/r&/;s/-/+/g'
33 prepare() {
34   cd $pkgname
35   NOCONFIGURE=1 ./autogen.sh
38 build() {
39   local configure_args=(
40     --prefix=/usr
41     --sysconfdir=/etc
42     --localstatedir=/var
43     --with-mdns=avahi
45     # Disable tests; get built into the library, adding a dep on libcheck
46     --disable-tests
48     # GTK-docs are broken when tests are disabled
49     --disable-gtk-doc
50   )
53   cd $pkgname
54   ./configure "${configure_args[@]}"
55   sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
56   make
59 package() {
60   cd $pkgname
61   make DESTDIR="$pkgdir" install
64 # vim:set sw=2 sts=-1 et: