db-move: moved webkitgtk-6.0 from [testing] to [extra] (x86_64)
[arch-packages.git] / libinih / repos / core-x86_64 / PKGBUILD
blob1213284138670deb5f16e655af201026f7624066
1 # Maintainer: Maxime Gauduin <alucryd@archlinux.org>
2 # Contributor: Alberto Oporto Ames <otreblain@gmail.com>
4 pkgname=libinih
5 pkgver=56
6 pkgrel=1
7 pkgdesc='A simple .INI file parser written in C'
8 arch=(x86_64)
9 url=https://github.com/benhoyt/inih
10 license=(BSD)
11 depends=(
12   gcc-libs
13   glibc
15 makedepends=(
16   git
17   meson
19 provides=(
20   libinih.so
21   libINIReader.so
23 _tag=5e1d9e2625842dddb3f9c086a50f22e4f45dfc2b
24 source=(git+https://github.com/benhoyt/inih.git#tag=${_tag})
25 b2sums=(SKIP)
27 pkgver() {
28   cd inih
29   git describe --tags | sed 's/^r//'
32 build() {
33   arch-meson inih build \
34     -Ddefault_library=shared \
35     -Ddistro_install=true \
36     -Dwith_INIReader=true
37   meson compile -C build
40 package() {
41   DESTDIR="$pkgdir" meson install -C build
42   install -Dm 644 inih/LICENSE.txt -t "${pkgdir}"/usr/share/licenses/libinih/
45 # vim: ts=2 sw=2 et: