db-move: moved webkitgtk-6.0 from [testing] to [extra] (x86_64)
[arch-packages.git] / libquotient / trunk / PKGBUILD
blob94db26f76f3b927f9725f6f2d1cab3075b8064fb
1 # Maintainer: Antonio Rojas <arojas@archlinux.org>
2 # Contributor: Alexey Andreyev <aa13q@ya.ru>
3 # Contributor Sefa Eyeoglu <contact@scrumplex.net>
5 pkgname=libquotient
6 pkgver=0.7.2
7 pkgrel=1
8 pkgdesc='A Qt library to write cross-platform clients for Matrix'
9 license=(LGPL)
10 arch=(x86_64)
11 url='https://matrix.org/docs/projects/sdk/quotient'
12 depends=(qt5-multimedia qtkeychain-qt5)
13 makedepends=(cmake)
14 source=(https://github.com/quotient-im/libQuotient/archive/$pkgver/$pkgname-$pkgver.tar.gz)
15 sha256sums=('62ff42c8fe321e582ce8943417c1d815ab3f373a26fa0d99a5926e713f6a9382')
17 build() {
18   cmake -B build -S libQuotient-$pkgver \
19     -DCMAKE_INSTALL_PREFIX=/usr \
20     -DCMAKE_BUILD_TYPE=None \
21     -DBUILD_SHARED_LIBS=ON
22   cmake --build build
25 package() {
26   DESTDIR="$pkgdir" cmake --install build