db-move: moved webkitgtk-6.0 from [testing] to [extra] (x86_64)
[arch-packages.git] / libwmf / repos / extra-x86_64 / PKGBUILD
blob94bc2b7cb59f338e0a0a400b93ba8280f7cb8ce6
1 # Maintainer: Eric BĂ©langer <eric@archlinux.org>
3 pkgname=libwmf
4 pkgver=0.2.12
5 pkgrel=3
6 pkgdesc="A library for reading vector images in Microsoft's native Windows Metafile Format (WMF)"
7 arch=('x86_64')
8 url="http://wvware.sourceforge.net/libwmf.html"
9 license=('LGPL')
10 depends=('libx11' 'libjpeg' 'gsfonts' 'freetype2' 'expat')
11 makedepends=('gtk2' 'libxt')
12 optdepends=('gdk-pixbuf2: for pixbuf loader')
13 options=('!docs' '!emptydirs')
14 source=($pkgname-$pkgver.tar.gz::https://github.com/caolanm/libwmf/archive/v$pkgver.tar.gz libwmf-freetype.patch)
15 sha256sums=('464ff63605d7eaf61a4a12dbd420f7a41a4d854675d8caf37729f5bc744820e2'
16             'c3b25a70ba55893fdd7637893a3852894260ed94c029f2b3916fc3df3fde32b8')
18 prepare() {
19   cd ${pkgname}-${pkgver}
20   patch -p1 -i ../libwmf-freetype.patch # Port away from freetype-config, patch from openembedded.org
21   autoreconf -vif -Ipatches
24 build() {
25   cd ${pkgname}-${pkgver}
26   ./configure --prefix=/usr \
27               --with-gsfontdir=/usr/share/fonts/Type1 \
28               --with-fontdir=/usr/share/fonts/Type1 \
29               --with-gsfontmap=/usr/share/ghostscript/9.10/Resource/Init/Fontmap.GS
30   make
33 package() {
34   cd ${pkgname}-${pkgver}
35   make DESTDIR="${pkgdir}" install -j1
36   #Remove fonts, these are in gsfonts
37   rm -rf "${pkgdir}/usr/share/fonts"