db-move: moved webkitgtk-6.0 from [testing] to [extra] (x86_64)
[arch-packages.git] / libxml++-5.0 / trunk / PKGBUILD
blobef97575c04e8f47b47ec717ebf9a77df8d319e12
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
3 pkgbase=libxml++-5.0
4 pkgname=(libxml++-5.0 libxml++-5.0-docs)
5 pkgver=5.0.3
6 pkgrel=1
7 pkgdesc="C++ bindings to libxml2"
8 url="https://libxmlplusplus.github.io/libxmlplusplus/"
9 arch=(x86_64)
10 license=(LGPL)
11 depends=(
12   gcc-libs
13   libxml2
15 makedepends=(
16   git
17   meson
18   mm-common
20 options=(!emptydirs)
21 _commit=81da7ce28c1aa71a18d5540b9d0d8cf2baba93b0  # tags/5.0.3^0
22 source=("git+https://github.com/libxmlplusplus/libxmlplusplus#commit=$_commit")
23 b2sums=('SKIP')
25 pkgver() {
26   cd libxmlplusplus
27   git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
30 prepare() {
31   cd libxmlplusplus
34 build() {
35   arch-meson libxmlplusplus build -D maintainer-mode=true
36   meson compile -C build
39 check() {
40   meson test -C build --print-errorlogs
43 package_libxml++-5.0() {
44   provides=(libxml++-5.0.so)
46   meson install -C build --destdir "$pkgdir"
48   # Split -docs
49   mkdir -p docs/usr/share
50   mv -t docs/usr/share "$pkgdir"/usr/share/{devhelp,doc}
53 package_libxml++-5.0-docs() {
54   pkgdesc+=" (documentation)"
55   depends=()
56   options=(!strip)
58   mv -t "$pkgdir" docs/*
61 # vim:set sw=2 sts=-1 et: