1 # Maintainer: Sébastien Luttringer
7 pkgdesc='Extremely fast compression algorithm'
9 url='https://lz4.github.io/lz4/'
12 checkdepends=('diffutils')
14 source=("git+https://github.com/lz4/lz4.git#tag=v$pkgver")
19 # apply patch from the source array (should be a pacman feature)
21 for src in "${source[@]}"; do
24 [[ $src = *.patch ]] || continue
25 msg2 "Applying patch $src..."
26 patch -Np1 < "../$src"
31 # do not use the main makefile, it calls sub make with -e
32 # exported CLFAGS by makepkg break the version. see FS#50071
34 make -C lib PREFIX=/usr
35 make -C programs PREFIX=/usr lz4 lz4c
40 $pkgname/programs/lz4 /etc/passwd passwd.lz4
41 $pkgname/programs/lz4 -d passwd.lz4 passwd
42 diff -q /etc/passwd passwd
48 make install PREFIX=/usr DESTDIR="$pkgdir"
51 # vim:set ts=2 sw=2 et: