db-move: moved webkitgtk-6.0 from [testing] to [extra] (x86_64)
[arch-packages.git] / numactl / trunk / PKGBUILD
blob72aad08cde69a10afeafa15697677dc1903590b6
1 # Maintainer: David Runge <dvzrv@archlinux.org>
2 # Contributor: Dan McGee <dan@archlinux.org>
3 # Contributor: Florian Zeitz <florob at babelmonkeys dot de>
5 pkgname=numactl
6 pkgver=2.0.16
7 pkgrel=1
8 pkgdesc="Simple NUMA policy support"
9 arch=(x86_64)
10 url="https://github.com/numactl/numactl"
11 license=(LGPL2.1 GPL2)
12 depends=(glibc)
13 provides=(libnuma.so)
14 source=($pkgname-$pkgver.tar.gz::$url/archive/refs/tags/v$pkgver.tar.gz)
15 sha512sums=('de89bd9f4a9be0e27b21d096aa17a554c209414b5d08b6a2dbd03f8f4830fe4fc5adc88fa8cb08ae1cf75884835dacbde5b6f5d31386244a2582924d2260fcb6')
16 b2sums=('bb19b771e2217cf39167877071623cfea14fa4560495e6c7d83b8f89b097ada93b142edbaba9f8ed1fdb61b20df075a8b0ca8898383d9ac34bb62bb9448447c0')
18 prepare(){
19   cd $pkgname-$pkgver
20   autoreconf -fiv
23 build() {
24   cd $pkgname-$pkgver
25   ./configure --prefix=/usr
26   make
29 check() {
30   make -k test -C $pkgname-$pkgver || echo "Tests known to fail depending on system load."
33 package() {
34   make DESTDIR="$pkgdir" install -C $pkgname-$pkgver
35   install -vDm 644 $pkgname-$pkgver/README.md -t "$pkgdir/usr/share/doc/$pkgname/"
36   # move_pages(2) is provided by man-pages and is more up-to-date there anyway
37   rm -rf "$pkgdir/usr/share/man/man2"