db-move: moved webkitgtk-6.0 from [testing] to [extra] (x86_64)
[arch-packages.git] / orc / repos / extra-x86_64 / PKGBUILD
blob8c10272ad745b4eb378444926f8c7da82ef083dd
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Ionut Biru <ibiru@archlinux.org>
3 # Contributor: Jan de Groot <jgc@archlinux.org>
5 pkgname=orc
6 pkgver=0.4.33
7 pkgrel=1
8 pkgdesc="Optimized Inner Loop Runtime Compiler"
9 url="https://gitlab.freedesktop.org/gstreamer/orc"
10 arch=(x86_64)
11 license=(custom:BSD)
12 depends=(glibc)
13 makedepends=(valgrind git gtk-doc meson)
14 options=(debug)
15 _commit=be26150a7ab2e19a0f9384109b97b6ed9c805cf6  # tags/0.4.33^0
16 source=("git+https://gitlab.freedesktop.org/gstreamer/orc.git#commit=$_commit")
17 sha256sums=('SKIP')
19 pkgver() {
20   cd orc
21   git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
24 prepare() {
25   cd orc
28 build() {
29   arch-meson orc build
30   meson compile -C build
33 check() {
34   meson test -C build --print-errorlogs
37 package() {
38   meson install -C build --destdir "$pkgdir"
39   install -Dt "$pkgdir/usr/share/licenses/$pkgname" -m644 orc/COPYING
42 # vim:set sw=2 sts=-1 et: