db-move: moved webkitgtk-6.0 from [testing] to [extra] (x86_64)
[arch-packages.git] / plank-player / trunk / PKGBUILD
blob154236a59e1d8504846599b0eecdf030c6cf8d77
1 # Maintainer: Antonio Rojas <arojas@archlinux.org>
3 pkgname=plank-player
4 pkgver=5.27.4
5 _dirver=$(echo $pkgver | cut -d. -f1-3)
6 pkgrel=1
7 pkgdesc='Multimedia Player for playing local files on Plasma Bigscreen allowing navigation with just a remote control'
8 arch=(x86_64)
9 url='https://plasma-bigscreen.org/'
10 license=(GPL2)
11 depends=(kirigami2 ki18n qt5-multimedia qt5-graphicaleffects hicolor-icon-theme)
12 makedepends=(extra-cmake-modules)
13 source=(https://download.kde.org/stable/plasma/$_dirver/$pkgname-$pkgver.tar.xz{,.sig})
14 sha256sums=('b674b85541751a5a33a3ade38fe9ccf27884d71d48290656a2766d4b88d9a018'
15             'SKIP')
16 validpgpkeys=('E0A3EB202F8E57528E13E72FD7574483BB57B18D'  # Jonathan Esk-Riddell <jr@jriddell.org>
17               '0AAC775BB6437A8D9AF7A3ACFE0784117FBCE11D'  # Bhushan Shah <bshah@kde.org>
18               'D07BD8662C56CB291B316EB2F5675605C74E02CF'  # David Edmundson <davidedmundson@kde.org>
19               '1FA881591C26B276D7A5518EEAAF29B42A678C20') # Marco Martin <notmart@gmail.com>
21 build() {
22   cmake -B build -S $pkgname-$pkgver \
23     -DBUILD_TESTING=OFF
24   cmake --build build
27 package() {
28   DESTDIR="$pkgdir" cmake --install build