1 # Maintainer: Antonio Rojas <arojas@archlinux.org>
2 # Maintainer: Felix Yan <felixonmars@archlinux.org>
4 pkgname=qt6-virtualkeyboard
9 url='https://www.qt.io'
10 license=(GPL3 LGPL3 FDL custom)
11 pkgdesc='Virtual keyboard framework'
12 depends=(qt6-declarative qt6-svg hunspell)
13 makedepends=(cmake ninja)
15 _pkgfn=${pkgname/6-/}-everywhere-src-$_qtver
16 source=(https://download.qt.io/official_releases/qt/${pkgver%.*}/$_qtver/submodules/$_pkgfn.tar.xz)
17 sha256sums=('7b45de78240817e9f4b57af821e4781655463a4f5f396bbc5df0580a7d2a0fa7')
20 cmake -B build -S $_pkgfn -G Ninja \
21 -DCMAKE_MESSAGE_LOG_LEVEL=STATUS \
22 -DQT_FEATURE_vkb_arrow_keynavigation=ON
27 DESTDIR="$pkgdir" cmake --install build
29 install -d "$pkgdir"/usr/share/licenses
30 ln -s /usr/share/licenses/qt6-base "$pkgdir"/usr/share/licenses/$pkgname