db-move: moved webkitgtk-6.0 from [testing] to [extra] (x86_64)
[arch-packages.git] / sdl2_mixer / trunk / PKGBUILD
blobcfbe3fa47234c19762efe6ed285764e2c354a6f7
1 # Maintainer: Sven-Hendrik Haase <svenstaro@archlinux.org>
2 pkgname=sdl2_mixer
3 pkgver=2.6.3
4 pkgrel=1
5 pkgdesc="A simple multi-channel audio mixer (Version 2)"
6 arch=('x86_64')
7 url="https://github.com/libsdl-org/SDL_mixer"
8 license=('MIT')
9 depends=('sdl2' 'libvorbis' 'libmodplug' 'mpg123' 'flac' 'opusfile')
10 makedepends=('fluidsynth')
11 optdepends=('fluidsynth: MIDI software synth, replaces built-in timidity')
12 source=("https://github.com/libsdl-org/SDL_mixer/releases/download/release-${pkgver}/SDL2_mixer-${pkgver}.tar.gz"{,.sig})
13 sha512sums=('2e9da045d2fdab97236c3901b3d441834a67a47c8851ddfb817c9db6f23ed9fb355a5ef8d2158d0c9959a83934e8cd1b95db8a69eaddf8f7fcca115f01818740'
14             'SKIP')
15 validpgpkeys=('1528635D8053A57F77D1E08630A59377A7763BE6')
17 build() {
18   cd "${srcdir}/SDL2_mixer-${pkgver}/"
20   # Fix https://bugs.archlinux.org/task/38428
21   sed -i "s|/etc/timidity.cfg|/etc/timidity/timidity.cfg|g" src/codecs/music_timidity.c
23   ./configure --disable-static --prefix=/usr
24   make
27 package() {
28   cd "${srcdir}/SDL2_mixer-${pkgver}/"
30   make DESTDIR="${pkgdir}" install
31   install -Dm644 LICENSE.txt "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"