db-move: moved webkitgtk-6.0 from [testing] to [extra] (x86_64)
[arch-packages.git] / xcb-util-keysyms / repos / extra-x86_64 / PKGBUILD
blob38558857731baea1baa05c90712621d02a00f4cd
1 # Maintainer: Andreas Radke <andyrtr@archlinux.org>
2 # Contributor: Jan de Groot <jgc@archlinux.org>
4 pkgname=xcb-util-keysyms
5 pkgver=0.4.1
6 pkgrel=4
7 pkgdesc="Utility libraries for XC Binding - Standard X key constants and conversion to/from keycodes"
8 arch=('x86_64')
9 url="https://xcb.freedesktop.org"
10 license=('custom')
11 depends=('libxcb')
12 makedepends=('xorg-util-macros' 'xorgproto')
13 options=('debug')
14 source=(https://xorg.freedesktop.org/archive/individual/lib/${pkgname}-${pkgver}.tar.xz{,.sig})
15 sha512sums=('dd53a36b52647f22bf0da8cded4b2974a51899eaac799797017ed8534f14bc2d2d339a14fa5ef387ae4528b7d9a5d31920bb0c71b09ca34f58e5081e768e2bbf'
16             'SKIP')
17 validpgpkeys=('4A193C06D35E7C670FA4EF0BA2FB9E081F2D130E') # Alan Coopersmith <alan.coopersmith@oracle.com>
19 build() {
20   cd ${pkgname}-${pkgver}
21   ./configure --prefix=/usr --disable-static
22   make
25 check() {
26   cd ${pkgname}-${pkgver}
27   make check
30 package() { 
31   cd ${pkgname}-${pkgver}
32   make DESTDIR="${pkgdir}" install
33   install -Dm644 COPYING "$pkgdir/usr/share/licenses/$pkgname/LICENSE"