db-move: moved webkitgtk-6.0 from [testing] to [extra] (x86_64)
[arch-packages.git] / xorg-xauth / trunk / PKGBUILD
blob2a70b49740e840faa8f586e74510a3601e62bc53
1 # Maintainer: Andreas Radke <andyrtr@archlinux.org>
3 pkgname=xorg-xauth
4 pkgver=1.1.2
5 pkgrel=1
6 pkgdesc="X.Org authorization settings program"
7 arch=(x86_64)
8 license=('custom')
9 url="https://xorg.freedesktop.org/"
10 depends=('libxmu')
11 makedepends=('xorg-util-macros')
12 groups=('xorg-apps' 'xorg')
13 source=(${url}/releases/individual/app/xauth-${pkgver}.tar.xz{,.sig})
14 sha512sums=('ac23fcd166b45abf7b030994ff3332c9906023dc1ddfa9b9d3000e6a914dc5e0213c4a2aa409cb3ddb93e1f9f4f6374376109241a95ef8c36af842de1f6f76e8'
15             'SKIP')
16 validpgpkeys=('3BB639E56F861FA2E86505690FDD682D974CA72A') # Matt Turner <mattst88@gmail.com>
17 #validpgpkeys+=('995ED5C8A6138EB0961F18474C09DD83CAAA50B2') # "Adam Jackson <ajax@nwnk.net>"
18 #validpgpkeys=('4A193C06D35E7C670FA4EF0BA2FB9E081F2D130E') # "Alan Coopersmith <alan.coopersmith@oracle.com>"
20 build() {
21   cd xauth-${pkgver}
22   ./configure --prefix=/usr
23   make
26 check() {
27   cd xauth-${pkgver}
28   make check
31 package() {
32   cd xauth-${pkgver}
33   make DESTDIR="${pkgdir}" install
34   install -d -m755 "${pkgdir}/usr/share/licenses/${pkgname}"
35   install -m644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/"