db-move: moved webkitgtk-6.0 from [testing] to [extra] (x86_64)
[arch-packages.git] / zenity / repos / extra-x86_64 / PKGBUILD
blob848dba94ebd2c93fa5d4d40b368c1e7ba87811f5
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Jan de Groot <jgc@archlinux.org>
4 pkgname=zenity
5 pkgver=3.44.0
6 pkgrel=3
7 pkgdesc="Display graphical dialog boxes from shell scripts"
8 url="https://gitlab.gnome.org/GNOME/zenity"
9 arch=(x86_64)
10 license=(LGPL)
11 depends=(
12   gtk3
13   libnotify
15 makedepends=(
16   git
17   meson
18   yelp-tools
20 optdepends=('perl: gdialog wrapper')
21 _commit=7bf8c8910d34bfb2b883b32118b93b68d44dd77b  # tags/3.44.0^0
22 source=("git+https://gitlab.gnome.org/GNOME/zenity.git#commit=$_commit")
23 sha256sums=('SKIP')
25 pkgver() {
26   cd zenity
27   git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
30 prepare() {
31   cd zenity
34 build() {
35   local meson_options=(
36     -D libnotify=true
37   )
39   arch-meson zenity build "${meson_options[@]}"
40   meson compile -C build
43 check() {
44   meson test -C build --print-errorlogs
47 package() {
48   meson install -C build --destdir "$pkgdir"
51 # vim:set sw=2 sts=-1 et: