1 # Maintainer: Antonio Rojas <arojas@archlinux.org>
2 # Contributor: Andrea Scarpino <andrea@archlinux.org>
3 # Contributor: Giovanni Scafora <giovanni@archlinux.org>
9 pkgdesc='C++ IDE using KDE technologies'
11 url='http://www.kdevelop.org/'
13 depends=(clang=$_clangver libksysguard kitemmodels knotifyconfig ktexteditor grantlee libkomparediff2 kcmutils threadweaver)
14 makedepends=(extra-cmake-modules kdoctools kdevelop-pg-qt llvm qt5-tools plasma-framework krunner okteta boost purpose subversion astyle)
15 optdepends=('konsole: embedded terminal'
16 'git: Git support' 'subversion: SVN support'
17 'gdb: GNU debugger support' 'lldb: LLDB debugger support'
18 'qt5-doc: Qt documentation integration'
19 'cmake: cmake integration'
20 'kate: for additional plugins'
21 'meson: meson integration'
22 'qt5-tools: qthelp plugin'
23 'okteta: GNU debugger support'
24 'plasma-framework: for the plasma addons'
25 'purpose: patch review plugin'
26 'astyle: astyle plugin'
27 'cppcheck: code analyzer' 'heaptrack: memory profiler'
28 'clazy: clazy analyzer plugin'
29 'kio-extras: man pages plugin')
30 conflicts=(kdevelop-qmljs kdevplatform)
31 replaces=(kdevelop-qmljs kdevplatform kdevelop-clang-tidy)
32 groups=(kde-applications kdevelop)
33 source=(https://download.kde.org/stable/release-service/$pkgver/src/$pkgname-$pkgver.tar.xz{,.sig})
34 sha256sums=('8d1fd187ec68bdf2e2ff3432e421141b1256bb1bb7ba4a328065013c5abdb4d0'
36 validpgpkeys=(CA262C6C83DE4D2FB28A332A3A6A4DB839EAA6D7 # Albert Astals Cid <aacid@kde.org>
37 F23275E4BF10AFC1DF6914A6DBD2CE893E2D1C87 # Christoph Feck <cfeck@kde.org>
38 D81C0CB38EB725EF6691C385BB463350D6EF31EF) # Heiko Becker <heiko.becker@kde.org>
41 cmake -B build -S $pkgname-$pkgver \
47 DESTDIR="$pkgdir" cmake --install build