archrelease: copy trunk to staging-x86_64
[arch-packages.git] / libgfshare / trunk / PKGBUILD
blobda90bf0bedba5eb6a3aa7cf5520afc0520740959
1 # Maintainer: Levente Polyak <anthraxx[at]archlinux[dot]org>
2 # Contributor: Alan Berndt <alan@eatabrick.org>
4 pkgname=libgfshare
5 pkgver=2.0.0
6 pkgrel=3
7 pkgdesc='Utilities for multi-way secret-sharing'
8 url='https://www.digital-scurf.org/software/libgfshare'
9 arch=('x86_64')
10 license=('MIT')
11 depends=('glibc')
12 provides=('libgfshare.so')
13 source=(https://www.digital-scurf.org/files/libgfshare/libgfshare-${pkgver}.tar.bz2)
14 sha512sums=('d6fd60a743825df85cb429b1dee583ab0a6d998fd5c79ee45b3da4c83a55970aee896337514c3686abfd3ff63099232e0f4af4203c32fa042500bfa8bc8d3495')
16 build() {
17   cd ${pkgname}-${pkgver}
18   ./configure --prefix=/usr
19   make
22 check() {
23   cd ${pkgname}-${pkgver}
24   make -k check
27 package() {
28   cd ${pkgname}-${pkgver}
29   make DESTDIR="${pkgdir}" install
30   install -Dm 644 COPYRIGHT -t "${pkgdir}/usr/share/licenses/${pkgname}"
31   install -Dm 644 README doc/theory.tex -t "${pkgdir}/usr/share/doc/${pkgname}"
34 # vim: ts=2 sw=2 et: