archrelease: copy trunk to staging-x86_64
[arch-packages.git] / libinput / trunk / PKGBUILD
blob2a2d9a5939a742e389cb59332598bc01c4b36071
1 # Maintainer: Andreas Radke <andyrtr@archlinux.org>
3 pkgname=libinput
4 pkgver=1.23.0
5 pkgrel=1
6 pkgdesc="Input device management and event handling library"
7 url="https://gitlab.freedesktop.org/libinput"
8 arch=(x86_64)
9 license=(custom:X11)
10 depends=('mtdev' 'systemd' 'libevdev' 'libwacom')
11 # upstream doesn't recommend building docs
12 makedepends=('gtk4' 'meson' 'wayland-protocols' 'check') # 'doxygen' 'graphviz' 'python-sphinx' 'python-recommonmark'
13 checkdepends=('python-pytest')
14 optdepends=('gtk4: libinput debug-gui'
15             'python-pyudev: libinput measure'
16             'python-libevdev: libinput measure')
17 source=(https://gitlab.freedesktop.org/libinput/libinput/-/archive/$pkgver/$pkgname-$pkgver.tar.bz2)
18 sha256sums=('fad7011705a21f500229199f789f3e3e794b4c9826b70073745cdaec23bc1d0b')
19 #validpgpkeys=('3C2C43D9447D5938EF4551EBE23B7E70B467F0BF') # Peter Hutterer (Who-T) <office@who-t.net>
21 build() {
22   arch-meson $pkgname-$pkgver build \
23     -D udev-dir=/usr/lib/udev \
24     -D documentation=false
26   # Print config
27   meson configure build
29   meson compile -C build
32 check() {
33   meson test -C build --print-errorlogs
36 package() {
37   meson install -C build --destdir "$pkgdir"
39   install -Dvm644 $pkgname-$pkgver/COPYING \
40     "$pkgdir/usr/share/licenses/$pkgname/LICENSE"