archrelease: copy trunk to staging-x86_64
[arch-packages.git] / python-dbusmock / trunk / PKGBUILD
blob534c85d6e4471d8d2207c8fee40aceae13aa3e9c
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
3 pkgname=python-dbusmock
4 pkgver=0.29.0
5 pkgrel=3
6 pkgdesc="Mock D-Bus objects for tests"
7 url="https://github.com/martinpitt/python-dbusmock"
8 arch=(any)
9 license=(LGPL3)
10 depends=(
11   python-dbus
12   python-gobject
14 makedepends=(
15   git
16   python-build
17   python-installer
18   python-setuptools
19   python-setuptools-scm
20   python-wheel
22 _commit=47509dff5fe8db42d5405a1f3a57a6ad8837e3eb  # tags/0.29.0^0
23 source=(
24   "git+https://github.com/martinpitt/python-dbusmock#commit=$_commit"
26 b2sums=('SKIP')
28 # Suppress local version
29 export SETUPTOOLS_SCM_PRETEND_VERSION="${pkgver%%+*}"
31 pkgver() {
32   cd $pkgname
33   git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
36 prepare() {
37   cd $pkgname
40 build() {
41   cd $pkgname
42   python -m build --wheel --no-isolation
45 package() {
46   cd $pkgname
47   python -m installer --destdir="$pkgdir" dist/*.whl
50 # vim:set sw=2 sts=-1 et: