archrelease: copy trunk to staging-x86_64
[arch-packages.git] / thunar / trunk / PKGBUILD
blob22fa8d8073bb87d2474b3e9ddbda3b4f697b96f7
1 # Maintainer: Evangelos Foutras <evangelos@foutrelis.com>
2 # Contributor: Andrew Simmons <andrew.simmons@gmail.com>
4 pkgname=thunar
5 pkgver=4.18.6
6 pkgrel=1
7 pkgdesc="Modern, fast and easy-to-use file manager for Xfce"
8 arch=('x86_64')
9 url="https://docs.xfce.org/xfce/thunar/start"
10 license=('GPL2' 'LGPL2.1')
11 groups=('xfce4')
12 depends=('desktop-file-utils' 'libexif' 'hicolor-icon-theme' 'libnotify'
13          'pcre2' 'libgudev' 'exo' 'libxfce4util' 'libxfce4ui' 'libpng')
14 makedepends=('intltool' 'gobject-introspection' 'xfce4-panel')
15 optdepends=('gvfs: trash support, mounting with udisk and remote filesystems'
16             'tumbler: thumbnail previews'
17             'thunar-volman: removable device management'
18             'thunar-archive-plugin: archive creation and extraction'
19             'thunar-media-tags-plugin: view/edit ID3/OGG tags')
20 source=(https://archive.xfce.org/src/xfce/$pkgname/${pkgver%.*}/$pkgname-$pkgver.tar.bz2)
21 sha256sums=('ee49b6e3fa1e7eac7f4d200ad6786d10f65721eb2cc18e36ce55a7195558140d')
23 prepare() {
24   cd $pkgname-$pkgver
27 build() {
28   cd $pkgname-$pkgver
30   ./configure \
31     --prefix=/usr \
32     --sysconfdir=/etc \
33     --enable-gio-unix \
34     --enable-gudev \
35     --enable-notifications \
36     --enable-exif \
37     --disable-debug
38   make
41 package() {
42   cd $pkgname-$pkgver
43   make DESTDIR="$pkgdir" install
46 # vim:set ts=2 sw=2 et: