archrelease: copy trunk to extra-x86_64
[arch-packages.git] / gcab / repos / extra-x86_64 / PKGBUILD
blob4f4e71e6a931f6c89e8627af6320477eb25630fc
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Jan de Groot <jgc@archlinux.org>
4 pkgname=gcab
5 pkgver=1.5
6 pkgrel=1
7 pkgdesc="A GObject library to create cabinet files"
8 url="https://wiki.gnome.org/msitools"
9 arch=(x86_64)
10 license=(LGPL)
11 depends=(glib2)
12 makedepends=(gobject-introspection vala git gtk-doc meson)
13 provides=(libgcab-1.0.so)
14 options=(debug)
15 _commit=d8054af4381dcef17ae691775c96a60116823047  # tags/v1.5^0
16 source=("git+https://gitlab.gnome.org/GNOME/gcab.git#commit=$_commit")
17 sha256sums=('SKIP')
19 pkgver() {
20   cd gcab
21   git describe --tags | sed 's/^v//;s/[^-]*-g/r&/;s/-/+/g'
24 prepare() {
25   cd gcab
28 build() {
29   arch-meson gcab build
30   meson compile -C build
33 check() {
34   meson test -C build --print-errorlogs
37 package() {
38   meson install -C build --destdir "$pkgdir"